XML'de Türkçe karakter sorunu

XML desteği ile yaptığınız Flash'larda çoğu zaman Türkçe karakterlerin yerine garip işaretler çıkar. Bu sorunu çözmek için birkaç kod yeterlidir.

XML desteği ile yaptığınız Flash'larda çoğu zaman Türkçe karakterlerin yerine garip işaretler çıkar. Bu sorunu çözmek için birkaç kod yeterlidir.

Flash ile XML üzerinden veri alıyorsunuz, fakat Türkçe karakterlerde sorun var. Nasıl olur da bu sorundan kurtulurum diyorsanız, XML dosyanızın başına:


xml version='1.0' encoding='windows-1254' ?>



kodunu yazmanız yeterlidir.

Ancak sorun yine çözülmedi ise, sorunu kökten halledecek olan diğer işlem şudur: Aşağıdaki kodu .fla dosyasındaki XML dosyasını çağırdığımız kodların en üst kısmına yazdığınızda işe yaradığını göreceksiniz. Ben şimdiye kadar bu kodları kullanıyorum ve herhangi bir şekilde TR sorunu ile karşılaşmadım.


System.useCodepage = true;





BİR BAŞKA YÖNTEM:

Daha önce bir yerlerde şöyle bir yöntemden de bahsediliyordu: Türkçe karakter bulunan bir XML dosyasını Metin Belgesi ile birlikte açıp birinci satırdaki:


xml version="1.0" encoding="ISO88599"?>



kodu yerine:


xml version="1.0" encoding="utf8"?>



kodunu yazarak kaydetmeden önce kodlama seçeneği kısmından "unicode" veya "utf8" seçerek kaydetmeniz durumunda sorun hallolacaktır.
  • Etiketler;
Siraceddin El
1999 yılından bu yana web tasarımcı olarak yurt içinde ve yurt dışında sayısız projede yer aldı. 2002 yılında Sanalkurs.net'i kuran ekiptendir. Etkinlik.com.tr'nin de kurucularındandır. Girişimci, tasarımcı ve eğitmen olarak çalışmalarını sürdürmektedir.
Yorum Yaz

Yorum yazabilmek için üye girişi yapmanız gerekiyor!

hahah işe yaradı:D thx...
Türkçe karakterler için evet işe yarıyor virgül gibi özel karakterlerde hala sıkıntı var
Teşekkürler işime çok yaradı.:kirp:
hocam acil yardım edersen sevinirim çalışmadı bir saatten beri uğraşıom yardımcı olursan sevinirim...
xml de resim nasıl çağrılır
teşekkürler
siraceddin kardeşim tamamen anlattıklarını yaptım birtek "ı" harfi çıkmıyo
video ile alakası olabilirmi siteye video eklediğimde bu dediklerinizin hiç biri bir işe yaramıyor:s
System.useCodepage = false; true değil de false yapınca benim karakterler düzeldi :) denedim şindi
çok çok teşekkürler :) herşeyi denedim olmadı taki aşağıdaki kodu yapıştırana kadar :) System.useCodepage = true;
hocam çok acil xml ye dosyama 最近在工业区建立国际住宿 ekleyemiyorum yani kutu kutu çıkıyor ne yapmam gerekiyor
latin hafleri okumuyo benim çalışma mail atıyorum deneme maili ? gözüküyo hep harflerin yerinde nasıl yaparız bunu
Aşağıdaki derste yer alan embed olayını uygulayın: http://www.sanalkurs.net/dinamik-metin-kutusuna-maske-vermek-432.html
üstad bende fla dosyası yok sadece xmlden çekiyor fakat hala düzenlenmiyor yukardakilerin hepsini yaptım
Bilgilendirme için teşekkürler.
hocam şöyle bi sıkıntı var bende swf dosyalar var ama fla dosyanlar yok dediklerinizi fla hariç diğerlerini uyguladım ama sonuç başarısız başka bi çözüm varmıdır benim durumuma?

Yukarı Git